pod updateが正常に実行できない

CocoaPods

環境

MacOS 10.14.5
CocoaPods 1.7.4

アップデートできない

既存のiOSアプリのプロジェクトのビルドターゲットを少し変更したので改めて、pod updateを実行してみたところ以下のエラーが出て正常にアップデートを実行できなかった。

### Error

LoadError - cannot load such file -- plist
/Users/username/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/Users/username/Documents/git/project/Podfile:69:in `block (2 levels) in from_ruby'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-core-1.7.2/lib/cocoapods-core/podfile.rb:179:in `post_install!'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:836:in `run_podfile_post_install_hook'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:824:in `block in run_podfile_post_install_hooks'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/user_interface.rb:145:in `message'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:823:in `run_podfile_post_install_hooks'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:309:in `block in create_and_save_projects'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/user_interface.rb:64:in `section'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:290:in `create_and_save_projects'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:281:in `generate_pods_project'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/installer.rb:159:in `install!'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/command/update.rb:62:in `run'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/claide-1.0.2/lib/claide/command.rb:334:in `run'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/lib/cocoapods/command.rb:52:in `run'
/Users/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/cocoapods-1.7.2/bin/pod:55:in `<top (required)>'
/Users/username/.rbenv/versions/2.5.0/bin/pod:23:in `load'
/Users/username/.rbenv/versions/2.5.0/bin/pod:23:in `<main>'

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

[!] Oh no, an error occurred.

Search for existing GitHub issues similar to yours:
https://github.com/CocoaPods/CocoaPods/search?q=cannot+load+such+file+--+plist&type=Issues

If none exists, create a ticket, with the template displayed above, on:
https://github.com/CocoaPods/CocoaPods/issues/new

Be sure to first read the contributing guide for details on how to properly submit a ticket:
https://github.com/CocoaPods/CocoaPods/blob/master/CONTRIBUTING.md

Don't forget to anonymize any private data!

Looking for related issues on cocoapods/cocoapods...
Searching for inspections failed: SSL_connect returned=1 errno=0 state=error: certificate verify failed (unable to get local issuer certificate)

Searching for inspections failed: SSL_connect returned=1 errno=0 state=error: certificate verify failed (unable to get local issuer certificate)
なんて出るものですから、最初は証明書関連が問題かと思いましたが、なんの事はありませんでした。

シンプルにcocoapodsが依存するgemがないだけでした。

Sudo gem install plist

これで正常に動きました。

しかし、なぜplistだけインストールされなかったのだろう…

Memo
連続企画

Djangoクラスベースビューのすヽめ

Memo
連続企画

Djangoでブログを作ろう

GitHub
制作物

Django-Boost

Djangoでの開発を加速する拡張ライブラリ
GitHub
制作物

ktPyString

kotlinにpythonと同等の文字列操作を提供するライブラリ
GitHub
制作物

py_string

c++にpythonと同等の文字列操作を提供するライブラリ
GitHub
制作物

SwiftyPyString

Swiftにpythonと同等の文字列操作を提供するライブラリ